Thursday, October 27, 2011

Can't add network in VMWare notes

While attempting to add an additional network in my VMWare environment, I was returned the popular "Call "HostNetworkSystem.UpdateNetworkConfig" for object "networkSystem" on ESXi "10.200.180.5" failed. Operation failed, diagnostics report: Error interacting with configuration file /etc/vmware/esx.conf: Write failed during Unlock. This is likely due to a full or read-only filesystem. Original Error was: Error interacting with configuration file /etc/vmware/esx.conf: Unable to write to file /etc/vmware/esx.conf.FcuxNQ while saving /etc/vmware/esx.conf operation aborted. It is likely this was caused by a Full Disk." error.

All documentation points to MAINSYS reaching a 32MB limit, likely a result of some run away IPMI errors or logging.

You can check volume usage by running "df -h" at the CLI, but to do so remotely, you need to enable remote tech support.

From the VSPhere client go to Configuration tab - Security Profile - Properties - Remote Tech Support (SSH) - Options button.  From there you can choose to Start Automatically, Start and Stop with host, or Start and Stop Manually.

When started, you can SSH to the host and run from CLI.

You can run "df -h" or "vdf -h" to identify issues.  Running vdf -h showed MAINSYS full at 32MB.

You can "ls -l" around to find offending files, in my case sel.raw and sel files unusually and relatively large.

cd /var/log/ipmi/0


-rw-r--r-- 1 root root 5800 Oct 25 19:55 fru
-rw-r--r-- 1 root root 17727 Oct 25 19:54 sdr_content.raw
-rw-r--r-- 1 root root 37 Oct 25 19:55 sdr_header.raw
-rw-r--r-- 1 root root 7208960 Oct 6 08:08 sel
-rw-r--r-- 1 root root 24600538 Oct 27 12:30 sel.raw
-rw-r--r-- 1 root root 35 Oct 27 12:30 sel_header.raw
-rw-r--r-- 1 root root 882 Oct 25 20:30 sensor_hysteresis.raw
-rw-r--r-- 1 root root 2676 Oct 25 20:30 sensor_readings.raw
-rw-r--r-- 1 root root 2192 Oct 25 20:30 sensor_threshold.raw

I won't comment on modifying IPMI settings or the safety of doing so, but you can remove the files via:

rm sel
rm sel.raw

/etc/init.d/sfcbd-watchdog restart


Additionally, on Cisco UCS systems, you can SSH to CIMC and investigate sel logging and clear them via:

Server# scope sel
Server /sel # show entries
Server /sel # clear

Unity Connection CLID when transfering off premise

Customer using CUCMBE 6.1 asked me to create a new auto attendant in Unity Connection for a new office.  Several of the caller input options resulted in the caller being transferred off premise.  I found that by default, the DN of the transferring voice mail port was being presented to the PSTN via the PRI.  Using an external mask on the voicemail ports, or transferring to a forwarded DN on a CTI Route Point with an external mask still presented the voicemail DNs.

Ultimately found that the CLID of the original caller can be passed by adjusting a CUCM service parameter.

See:

System - Service Parameters - - Cisco CallManager - Clusterwide Parameters (Device - Phone) - Display Original Calling Number on Transfer from Cisco Unity

The default is False.  When changing to True, the external destination number is presented with the CLID of the original external caller.

Nice.

Wednesday, October 26, 2011

CUCM forwarding destination SQL query examples

This is just a repost of William Bell's great answer to a CUCM forward destination report question at https://supportforums.cisco.com/thread/2010685 . 

It's another really great and practical example of what's possible via SQL in CUCM.  Thank you William Bell for your time and information sharing.With some minor tweaks, it provided me with what I was looking for today in moments.

There is no native report in CUCM that can retrieve this information but you can use a SQL query (ether from the command line or via SQL Query Tool). Command line example of what you seek:

admin: run sql select d.name as device, n.dnorpattern, cfd.cfadestination from device as d inner join devicenumplanmap as dmap on dmap.fkdevice = d.pkid inner join numplan as n on n.pkid=dmap.fknumplan inner join callforwarddynamic as cfd on cfd.fknumplan=n.pkid where (cfd.cfadestination != '')

If you have an interest in seeing stations that are call forwarded to voicemail AND other destinations, then the following query can be used:

admin: run sql select d.name as device, n.dnorpattern, cfd.cfadestination from device as d inner join devicenumplanmap as dmap on dmap.fkdevice = d.pkid inner join numplan as n on n.pkid=dmap.fknumplan inner join callforwarddynamic as cfd on cfd.fknumplan=n.pkid where ((cfd.cfadestination != '') or (cfd.cfaVoicemailEnabled='t'))

If you are looking for a particular number like 17035551212 as the call forward destination, then the following could be used:

admin: run sql select d.name as device, n.dnorpattern, cfd.cfadestination from device as d inner join devicenumplanmap as dmap on dmap.fkdevice = d.pkid inner join numplan as n on n.pkid=dmap.fknumplan inner join callforwarddynamic as cfd on cfd.fknumplan=n.pkid where (cfd.cfadestination = '917035551212')

(NOTE: The above assumes that the off net access code is "9")

http://www.netcraftsmen.net/resources/blogs/running-sql-queries-on-cucm-6x7x-using-axl-soap-toolkit-part-1.html


Can ping across WAN but can't telnet

Switch A -> Router A -> 20Mb fiber WAN -> Router B

  •  Router A and Router B can ping and telnet to each other.
  • Hosts at site B have access to all resources at and beyond Site A using Router B as gateway.
  • Switch A can ping Router B but cannot telnet to it.  There are no ACLs and debug telnet shows nothing.
  • Router B can ping Switch A but cannot telnet to it.  Again, no ACLs and no debug output.

Long story short,  had to manually enter "ip classless" on Router B, despite supposedly being enabled by default.
 
The big problem here was Router B is also a voice gateway off a CUCM at site A.  Although MGCP FXO ports show registered in CUCM, show ccm-manager on the gateway indicates the CUCM as down.  The analog ports will only get a new configuration if I no ccm-manager config and ccm-manager config again, although call processing worked.

There is probably more to this story, but I haven't found it yet.  Moving on...

  
Router A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.203.3.250 to network 0.0.0.0
10.0.0.0/24 is subnetted, 4 subnets
C 10.201.201.0 is directly connected, GigabitEthernet0/1
C 10.203.3.0 is directly connected, GigabitEthernet0/0
S 10.203.10.0 [1/0] via 10.201.201.202
S 10.203.12.0 [1/0] via 10.201.201.202
S* 0.0.0.0/0 [1/0] via 10.203.3.250

Router A#sh ip int b
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 10.203.3.5 YES NVRAM up up
GigabitEthernet0/1 10.201.201.201 YES manual up up

  
Switch A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.203.4.254 to network 0.0.0.0
172.31.0.0/24 is subnetted, 1 subnets
C 172.31.254.0 is directly connected, Vlan5
10.0.0.0/8 is variably subnetted, 19 subnets, 3 masks
S 10.201.201.0/24 [1/0] via 10.203.3.5
S 10.11.253.247/32 [1/0] via 10.12.232.1
S 10.70.4.0/22 [1/0] via 10.12.232.1
S 10.0.104.0/22 [1/0] via 10.12.232.1
S 10.0.100.0/22 [1/0] via 10.12.232.1
S 10.11.244.130/32 [1/0] via 10.12.232.1
S 10.11.253.113/32 [1/0] via 10.12.232.1
S 10.110.213.32/32 [1/0] via 10.12.232.1
C 10.203.3.0/24 is directly connected, Vlan3
S 10.10.220.30/32 [1/0] via 10.12.232.1
S 10.203.5.0/24 [1/0] via 10.203.4.254
C 10.203.4.0/24 is directly connected, Vlan4
S 10.203.6.0/24 [1/0] via 10.203.4.254
S 10.203.10.0/24 [1/0] via 10.203.3.5
S 10.203.12.0/24 [1/0] via 10.203.3.5
S 10.10.220.7/32 [1/0] via 10.12.232.1
S 10.10.219.0/24 [1/0] via 10.12.232.1
S 10.60.208.0/22 [1/0] via 10.12.232.1
C 10.12.232.0/22 is directly connected, GigabitEthernet0/40
S* 0.0.0.0/0 [1/0] via 10.203.4.254

Router B#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is 10.201.201.201 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 10.201.201.201
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.201.201.0/24 is directly connected, GigabitEthernet0/0
L 10.201.201.202/32 is directly connected, GigabitEthernet0/0
C 10.203.10.0/24 is directly connected, GigabitEthernet0/1.1
L 10.203.10.1/32 is directly connected, GigabitEthernet0/1.1
C 10.203.12.0/24 is directly connected, GigabitEthernet0/1.100
L 10.203.12.1/32 is directly connected, GigabitEthernet0/1.100
72.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 72.88.81.0/24 is directly connected, GigabitEthernet0/2
L 72.88.81.202/32 is directly connected, GigabitEthernet0/2
Router B#sh ip int b
Interface IP-Address OK? Method Status Protocol
Embedded-Service-Engine0/0 unassigned YES NVRAM administratively down down
GigabitEthernet0/0 10.201.201.202 YES NVRAM up up
GigabitEthernet0/1 unassigned YES NVRAM up up
GigabitEthernet0/1.1 10.203.10.1 YES NVRAM up up
GigabitEthernet0/1.100 10.203.12.1 YES NVRAM up up
GigabitEthernet0/2 72.88.81.202 YES NVRAM up up

Monday, October 24, 2011

UC520 or CME / CUE basic config with VPN and WiFi off

Although the Cisco Configuration Assistant is still a bit foreign to me (coming from a CME / CUE background), it certainly does makes basic start up and configuration tasks easy. 

The only issues I have found so far is the FXO trunk group preferences seem to get mangled, and creating station hunt groups via the Telephony Configuration Wizard seems to be broken, or more trouble than it's worth.  I also haven't thought about why digits AAAA and ABC are used in some dial-peer patterns yet, but I'm guessing CCA needs to put something there by design.  Weird.

For reference, here is a complete but basic UC520 CLI configuration, including easy VPN access and the wireless radio configured, but shut down.

UC520_MyCompany#sh run
Building configuration...
Current configuration : 33865 bytes
!
! Last configuration change at 07:37:48 EDT Mon Oct 24 2011 by cisco
!
version 15.1
parser config cache interface
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname UC520_MyCompany
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$FNkF$NPq0pyaK8FAVQN9bmnjS7/
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login tango_authen_login line local
aaa authentication login Foxtrot_sdm_easyvpn_xauth_ml_1 local
aaa authorization exec tango_author_exec if-authenticated
aaa authorization network Foxtrot_sdm_easyvpn_group_ml_1 local
!
!
!
!
!
aaa session-id common
!
clock timezone EST -5 0
clock summer-time EDT recurring
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-4130517448
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4130517448
revocation-check none
!
!
crypto pki certificate chain TP-self-signed-4130517448
certificate self-signed 01
30820251 308201BA A0030201 02020101 300D0609 2A864886 F70D0101 04050030
Blah blah blah
B33D13D81 F207908B 28A35039 3D9E3510 4C9786AB 9A
quit
dot11 syslog
!
dot11 ssid cisco-data
vlan 1
authentication open
authentication key-management wpa
wpa-psk ascii 0 cisco123
!
dot11 ssid cisco-voice
vlan 100
authentication open
authentication key-management wpa
wpa-psk ascii 0 cisco123
!
ip source-route
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.1.1.1 10.1.1.9
ip dhcp excluded-address 10.1.1.241 10.1.1.255
ip dhcp excluded-address 192.168.10.1 192.168.10.9
ip dhcp excluded-address 192.168.10.241 192.168.10.255
!
ip dhcp pool phone
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
option 150 ip 10.1.1.1
!
ip dhcp pool data
import all
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
!
!
ip domain name mycompany.com
ip name-server 192.168.1.20
ip name-server 4.2.2.2
ip inspect WAAS flush-timeout 10
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp router-traffic
ip inspect name SDM_LOW udp router-traffic
ip inspect name SDM_LOW vdolive
no ipv6 cef
!
multilink bundle-name authenticated
!
stcapp ccm-group 1
stcapp
!
!
!
!
trunk group ALL_FXO
max-retry 5
voice-class cause-code 1
hunt-scheme longest-idle
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
sip
no update-callerid
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class custom-cptone CCAjointone
dualtone conference
frequency 600 900
cadence 300 150 300 100 300 50
!
voice class custom-cptone CCAleavetone
dualtone conference
frequency 400 800
cadence 400 50 200 50 200 50
!
!
voice class cause-code 1
no-circuit
!
voice register global
!
!
!
voice translation-rule 1000
rule 1 /.*/ //
!
voice translation-rule 1112
rule 1 /^9/ //
!
voice translation-rule 2001
!
voice translation-rule 2002
rule 1 /^6/ //
!
voice translation-rule 2222
rule 1 /^91900......./ //
rule 2 /^91976......./ //
!
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
translate calling 1111
!
voice translation-profile CallBlocking
translate called 2222
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate called 1112
!
voice translation-profile XFER_TO_VM_PROFILE
translate redirect-called 2002
!
voice translation-profile nondialable
translate called 1000
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
fax interface-type fax-mail
!
!
license udi pid UC520W-8U-4FXO-K9 sn FHK112816TM
archive
log config
logging enable
logging size 600
hidekeys
username cisco privilege 15 secret 5 $1$AxRNblahblahblah.7slT5CPX88G.
!
!
ip tftp source-interface Loopback0
!
class-map match-all _class_Voice0
match ip dscp ef
class-map match-all _class_Voice1
match ip dscp cs3
!
!
policy-map Voice
class _class_Voice0
set cos 6
class _class_Voice1
set cos 3
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
!
crypto isakmp client configuration group EZVPN_GROUP_1
key ciscocisco
dns 192.168.1.20 4.2.2.2
pool SDM_POOL_1
save-password
max-users 10
crypto isakmp profile sdm-ike-profile-1
match identity group EZVPN_GROUP_1
client authentication list Foxtrot_sdm_easyvpn_xauth_ml_1
isakmp authorization list Foxtrot_sdm_easyvpn_group_ml_1
client configuration address respond
virtual-template 1
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto ipsec profile SDM_Profile1
set transform-set ESP-3DES-SHA
set isakmp-profile sdm-ike-profile-1
!
!
bridge irb
!
!
!
!
interface Loopback0
description $FW_INSIDE$
ip address 10.1.10.2 255.255.255.252
ip access-group 101 in
ip nat inside
ip virtual-reassembly in
!
interface FastEthernet0/0
description $FW_OUTSIDE$
ip address 192.168.1.45 255.255.255.0
ip access-group 104 in
ip verify unicast reverse-path
ip nat outside
ip inspect SDM_LOW out
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
!
interface Integrated-Service-Engine0/0
description cue is initialized with default IMAP group
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly in
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1/0
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/1
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/2
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/3
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/4
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/5
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/6
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/7
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/8
switchport mode trunk
switchport voice vlan 100
macro description cisco-switch
!
interface Dot11Radio0/5/0
no ip address
shutdown
!
encryption vlan 1 mode ciphers aes-ccm
!
encryption vlan 100 mode ciphers aes-ccm
!
ssid cisco-data
!
ssid cisco-voice
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2437
station-role root
antenna receive right
antenna transmit right
world-mode dot11d country US indoor
service-policy output Voice
!
interface Dot11Radio0/5/0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0/5/0.100
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 subscriber-loop-control
bridge-group 100 spanning-disabled
bridge-group 100 block-unknown-source
no bridge-group 100 source-learning
no bridge-group 100 unicast-flooding
!
interface Virtual-Template1 type tunnel
ip unnumbered BVI1
ip nat inside
ip virtual-reassembly in
tunnel mode ipsec ipv4
tunnel protection ipsec profile SDM_Profile1
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan100
no ip address
bridge-group 100
bridge-group 100 spanning-disabled
!
interface BVI1
description $FW_INSIDE$
ip address 192.168.10.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly in
!
interface BVI100
description $FW_INSIDE$
ip address 10.1.1.1 255.255.255.0
ip access-group 103 in
ip nat inside
ip virtual-reassembly in
!
ip local pool SDM_POOL_1 192.168.0.5 192.168.0.6
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
ip dns server
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
logging esm config
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny ip 192.168.10.0 0.0.0.255 any
access-list 100 deny ip host 255.255.255.255 any
access-list 100 deny ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by SDM firewall configuration##NO_ACES_8##
access-list 101 remark SDM_ACL Category=1
access-list 101 permit udp any host 10.1.10.2 eq non500-isakmp
access-list 101 permit udp any host 10.1.10.2 eq isakmp
access-list 101 permit esp any host 10.1.10.2
access-list 101 permit ahp any host 10.1.10.2
access-list 101 permit tcp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 permit udp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 deny ip 10.1.1.0 0.0.0.255 any
access-list 101 deny ip 192.168.10.0 0.0.0.255 any
access-list 101 deny ip 192.168.1.0 0.0.0.255 any
access-list 101 deny ip host 255.255.255.255 any
access-list 101 deny ip 127.0.0.0 0.255.255.255 any
access-list 101 permit ip any any
access-list 102 remark auto generated by SDM firewall configuration##NO_ACES_6##
access-list 102 remark SDM_ACL Category=1
access-list 102 permit udp any host 192.168.10.1 eq non500-isakmp
access-list 102 permit udp any host 192.168.10.1 eq isakmp
access-list 102 permit esp any host 192.168.10.1
access-list 102 permit ahp any host 192.168.10.1
access-list 102 deny ip 10.1.10.0 0.0.0.3 any
access-list 102 deny ip 10.1.1.0 0.0.0.255 any
access-list 102 deny ip 192.168.1.0 0.0.0.255 any
access-list 102 deny ip host 255.255.255.255 any
access-list 102 deny ip 127.0.0.0 0.255.255.255 any
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration##NO_ACES_8##
access-list 103 remark SDM_ACL Category=1
access-list 103 permit udp any host 10.1.1.1 eq non500-isakmp
access-list 103 permit udp any host 10.1.1.1 eq isakmp
access-list 103 permit esp any host 10.1.1.1
access-list 103 permit ahp any host 10.1.1.1
access-list 103 permit tcp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 deny ip 10.1.10.0 0.0.0.3 any
access-list 103 deny ip 192.168.10.0 0.0.0.255 any
access-list 103 deny ip 192.168.1.0 0.0.0.255 any
access-list 103 deny ip host 255.255.255.255 any
access-list 103 deny ip 127.0.0.0 0.255.255.255 any
access-list 103 permit ip any any
access-list 104 remark auto generated by SDM firewall configuration##NO_ACES_15##
access-list 104 remark SDM_ACL Category=1
access-list 104 permit udp any host 192.168.1.45 eq non500-isakmp
access-list 104 permit udp any host 192.168.1.45 eq isakmp
access-list 104 permit esp any host 192.168.1.45
access-list 104 permit ahp any host 192.168.1.45
access-list 104 deny ip 10.1.10.0 0.0.0.3 any
access-list 104 deny ip 10.1.1.0 0.0.0.255 any
access-list 104 deny ip 192.168.10.0 0.0.0.255 any
access-list 104 permit udp host 192.168.1.20 eq domain any
access-list 104 permit udp host 4.2.2.2 eq domain any
access-list 104 permit icmp any host 192.168.1.45 echo-reply
access-list 104 permit icmp any host 192.168.1.45 time-exceeded
access-list 104 permit icmp any host 192.168.1.45 unreachable
access-list 104 deny ip 10.0.0.0 0.255.255.255 any
access-list 104 deny ip 172.16.0.0 0.15.255.255 any
access-list 104 deny ip 192.168.0.0 0.0.255.255 any
access-list 104 deny ip 127.0.0.0 0.255.255.255 any
access-list 104 deny ip host 255.255.255.255 any
access-list 104 deny ip host 0.0.0.0 any
access-list 104 deny ip any any log
!
!
!
!
snmp-server community public RO
tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin
tftp-server flash:/phones/7906_7911/apps11.8-5-4TH1-6.sbn alias apps11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/cnu11.8-5-4TH1-6.sbn alias cnu11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/cvm11sccp.8-5-4TH1-6.sbn alias cvm11sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/dsp11.8-5-4TH1-6.sbn alias dsp11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/jar11sccp.8-5-4TH1-6.sbn alias jar11sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/SCCP11.8-5-4S.loads alias SCCP11.8-5-4S.loads
tftp-server flash:/phones/7906_7911/term06.default.loads alias term06.default.loads
tftp-server flash:/phones/7906_7911/term11.default.loads alias term11.default.loads
tftp-server flash:/phones/7941_7961/apps41.8-5-4TH1-6.sbn alias apps41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/cnu41.8-5-4TH1-6.sbn alias cnu41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/cvm41sccp.8-5-4TH1-6.sbn alias cvm41sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/dsp41.8-5-4TH1-6.sbn alias dsp41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/jar41sccp.8-5-4TH1-6.sbn alias jar41sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/SCCP41.8-5-4S.loads alias SCCP41.8-5-4S.loads
tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Desktops/CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
radius-server attribute 31 send nas-port-detail
!
!
control-plane
!
bridge 1 route ip
bridge 100 route ip
!
voice-port 0/0/0
station-id number 401
caller-id enable
!
voice-port 0/0/1
station-id number 402
caller-id enable
!
voice-port 0/0/2
station-id number 403
caller-id enable
!
voice-port 0/0/3
station-id number 404
caller-id enable
!
voice-port 0/1/0
trunk-group ALL_FXO 64
connection plar opx 398
description Configured by CCA 4 FXO-0/1/0-AA
caller-id enable
!
voice-port 0/1/1
trunk-group ALL_FXO 64
connection plar opx 398
description Configured by CCA 4 FXO-0/1/1-AA
caller-id enable
!
voice-port 0/1/2
trunk-group ALL_FXO 64
connection plar opx 398
description Configured by CCA 4 FXO-0/1/2-AA
caller-id enable
!
voice-port 0/1/3
trunk-group ALL_FXO 64
connection plar opx 398
description Configured by CCA 4 FXO-0/1/3-AA
caller-id enable
!
voice-port 0/2/0
station-id number 405
caller-id enable
!
voice-port 0/2/1
station-id number 406
caller-id enable
!
voice-port 0/2/2
station-id number 407
caller-id enable
!
voice-port 0/2/3
station-id number 408
caller-id enable
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control -15
description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.1.1.1 identifier 1 version 4.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register confprof1
!
dspfarm profile 1 conference
description DO NOT MODIFY, active CCA conference profile - CCA2.0 codec711
codec g711ulaw
codec g711alaw
maximum conference-participants 32
maximum sessions 2
conference-join custom-cptone CCAjointone
conference-leave custom-cptone CCAleavetone
associate application SCCP
!
dial-peer cor custom
name internal
name local
name local-plus
name international
name national
name national-plus
name emergency
name toll-free
!
!
dial-peer cor list call-internal
member internal
!
dial-peer cor list call-local
member local
!
dial-peer cor list call-local-plus
member local-plus
!
dial-peer cor list call-national
member national
!
dial-peer cor list call-national-plus
member national-plus
!
dial-peer cor list call-international
member international
!
dial-peer cor list call-emergency
member emergency
!
dial-peer cor list call-toll-free
member toll-free
!
dial-peer cor list user-internal
member internal
member emergency
!
dial-peer cor list user-local
member internal
member local
member emergency
member toll-free
!
dial-peer cor list user-local-plus
member internal
member local
member local-plus
member emergency
member toll-free
!
dial-peer cor list user-national
member internal
member local
member local-plus
member national
member emergency
member toll-free
!
dial-peer cor list user-national-plus
member internal
member local
member local-plus
member national
member national-plus
member emergency
member toll-free
!
dial-peer cor list user-international
member internal
member local
member local-plus
member international
member national
member national-plus
member emergency
member toll-free
!
!
dial-peer voice 1 pots
destination-pattern 401
port 0/0/0
no sip-register
!
dial-peer voice 2 pots
destination-pattern 402
port 0/0/1
no sip-register
!
dial-peer voice 3 pots
destination-pattern 403
port 0/0/2
no sip-register
!
dial-peer voice 4 pots
destination-pattern 404
port 0/0/3
no sip-register
!
dial-peer voice 5 pots
description ** MOH Port **
destination-pattern ABC
port 0/4/0
no sip-register
!
dial-peer voice 6 pots
description catch all dial peer for BRI/PRI^T
translation-profile incoming nondialable
incoming called-number .%
direct-inward-dial
!
dial-peer voice 50 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
port 0/1/0
!
dial-peer voice 51 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
port 0/1/1
!
dial-peer voice 52 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
port 0/1/2
!
dial-peer voice 53 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
port 0/1/3
!
dial-peer voice 54 pots
description ** FXO pots dial-peer **
destination-pattern A0
port 0/1/0
no sip-register
!
dial-peer voice 55 pots
description ** FXO pots dial-peer **
destination-pattern A1
port 0/1/1
no sip-register
!
dial-peer voice 56 pots
description ** FXO pots dial-peer **
destination-pattern A2
port 0/1/2
no sip-register
!
dial-peer voice 57 pots
description ** FXO pots dial-peer **
destination-pattern A3
port 0/1/3
no sip-register
!
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
translation-profile outgoing XFER_TO_VM_PROFILE
destination-pattern 399
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2001 voip
description ** cue auto attendant number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 398
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2012 voip
description ** cue prompt manager number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 397
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1100 pots
destination-pattern 405
port 0/2/0
no sip-register
!
dial-peer voice 1101 pots
destination-pattern 406
port 0/2/1
no sip-register
!
dial-peer voice 1102 pots
destination-pattern 407
port 0/2/2
no sip-register
!
dial-peer voice 1103 pots
destination-pattern 408
port 0/2/3
no sip-register
!
dial-peer voice 58 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*North American-7-Digit*Emergency**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9911
forward-digits all
no sip-register
!
dial-peer voice 59 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*North American-7-Digit*Emergency**
preference 5
destination-pattern 911
forward-digits all
no sip-register
!
dial-peer voice 60 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*North American-7-Digit*7-Digit Local**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]......
forward-digits all
no sip-register
!
dial-peer voice 61 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*North American-7-Digit*Service Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]11
forward-digits all
no sip-register
!
dial-peer voice 62 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*North American-7-Digit*Long Distance**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91[2-9]..[2-9]......
forward-digits all
no sip-register
!
dial-peer voice 63 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*North American-7-Digit*International**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9011T
forward-digits all
no sip-register
!
dial-peer voice 64 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91800.......
forward-digits all
no sip-register
!
dial-peer voice 65 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91888.......
forward-digits all
no sip-register
!
dial-peer voice 66 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91877.......
forward-digits all
no sip-register
!
dial-peer voice 67 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91866.......
forward-digits all
no sip-register
!
dial-peer voice 68 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91855.......
forward-digits all
no sip-register
!
!
no dial-peer outbound status-check pots
!
!
telephony-service
sdspfarm conference mute-on 111 mute-off 222
sdspfarm units 5
sdspfarm tag 1 confprof1
conference hardware
video
fxo hook-flash
max-ephones 14
max-dn 56
ip source-address 10.1.1.1 port 2000
auto assign 1 to 1 type bri
calling-number initiator
service phone videoCapability 1
service phone ehookenable 1
service phone SPA525-Encryption-key cisco123
service phone SPA525-wifi-on yes
service phone SPA525-protocol SPCP
service phone SPA525-auto-detect-sccp yes
service phone SPA525-http-write yes
service phone SPA525-SSID cisco-voice
service phone SPA525-readonly no
service phone SPA525-Encryption-type WPA2_PSK
service dnis overlay
service dnis dir-lookup
service dss
timeouts interdigit 5
system message IPLogic MyCompany UC520
url services http://10.1.10.1/voiceview/common/login.do
url authentication http://10.1.10.1/voiceview/authentication/authenticate.do
cnf-file location flash:
cnf-file perphone
load 7906 SCCP11.8-5-4S
load 7911 SCCP11.8-5-4S
load 7941 SCCP41.8-5-4S
load 7941GE SCCP41.8-5-4S
load 7961 SCCP41.8-5-4S
load 7961GE SCCP41.8-5-4S
load 521G-524G cp524g-8-1-17
time-zone 12
keepalive 30 auxiliary 4
voicemail 399
max-conferences 8 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:/media/music-on-hold.au
multicast moh 239.10.16.16 port 2000
web admin system name cisco secret 5 $1$LueE$BYPOgzzgSJk4ep/WZBDMN0
dn-webedit
time-webedit
transfer-system full-consult dss
transfer-pattern 9.T
transfer-pattern .T
transfer-pattern 6... blind
secondary-dialtone 9
night-service day Sun 17:00 09:00
night-service day Mon 17:00 09:00
night-service day Tue 17:00 09:00
night-service day Wed 17:00 09:00
night-service day Thu 17:00 09:00
night-service day Fri 17:00 09:00
night-service day Sat 17:00 09:00
night-service date Jan 1 00:00 23:59
night-service date Dec 25 00:00 23:59
fac standard
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-template 15
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use Newcall
softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
button-layout 7931 2
!
!
ephone-template 16
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use Newcall
softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
!
!
ephone-template 17
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use CBarge Newcall
softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
!
!
ephone-template 18
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use CBarge Newcall
softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
button-layout 7931 2
!
!
ephone-dn 9
number BCD no-reg primary
description MoH
moh out-call ABC
!
!
ephone-dn 42 octo-line
number 771 no-reg primary
conference meetme unlocked
preference 3
!
!
ephone-dn 43 octo-line
number 771 no-reg primary
conference meetme unlocked
preference 2
no huntstop
!
!
ephone-dn 44 octo-line
number 771 no-reg primary
conference meetme unlocked
preference 1
no huntstop
!
!
ephone-dn 45 octo-line
number 771 no-reg primary
conference meetme unlocked
no huntstop
!
!
ephone-dn 46 octo-line
number C001 no-reg primary
conference ad-hoc
preference 3
!
!
ephone-dn 47 octo-line
number C001 no-reg primary
conference ad-hoc
preference 2
no huntstop
!
!
ephone-dn 48 octo-line
number C001 no-reg primary
conference ad-hoc
preference 1
no huntstop
!
!
ephone-dn 49 octo-line
number C001 no-reg primary
conference ad-hoc
no huntstop
!
!
ephone-dn 50 octo-line
number 200 no-reg primary
label Demo User Three 200
description 8007654321
name Demo UserThree
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn 51 dual-line
number 202 no-reg primary
label User One 202
description 8007654321
name Demo Userone
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn 52
number 700 no-reg primary
park-slot timeout 30 limit 2 recall retry 30 limit 2
label Park Slot 700
!
!
ephone-dn 53 octo-line
number 201 no-reg primary
label Demo User Two 201
description 8007654321
name Demo Usertwo
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn 54
number 6... no-reg primary
description ***CCA XFER TO VM EXTENSION***
call-forward all 399
!
!
ephone-dn 55
number A801... no-reg primary
mwi off
!
!
ephone-dn 56
number A800... no-reg primary
mwi on
!
!
ephone 3
device-security-mode none
video
mac-address 001B.D47D.F875
ephone-template 16
username "Demouserone" password 123456
type 7911
button 1:51
!
!
!
ephone 4
device-security-mode none
mac-address 0017.9515.E8FF
ephone-template 16
username "Demousertwo" password 123456
type 7941
button 1:53
!
!
!
ephone 5
device-security-mode none
video
mac-address 0017.9402.DACE
ephone-template 16
username "Demouserthree" password 123456
type 7961
button 1:50
!
!
alias exec cca_voice_mode PBX
banner login ^Cbanner login ^Cisco Configuration Assistant. Version: 3.1 (1). Sat Oct 22 17:17:58 EDT 2011^^C
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
password cisco
authorization exec tango_author_exec
login authentication tango_authen_login
transport preferred none
transport input all
line vty 5 100
password cisco
authorization exec tango_author_exec
login authentication tango_authen_login
transport preferred none
transport input all
!
ntp master
ntp server time.nist.gov prefer
end

UC520_MyCompany#

Monday, October 10, 2011

SNR, RSSI, EIRP, etc.

This is just a repost of  https://supportforums.cisco.com/docs/DOC-12954 .  Thought it was an excellent high level summary of critical WiFi elements that I didn't want to loose:

Signal to Noise Ratio (SNR)


The power level of the RF signal relative to the power level of the noise floor is known as the Signal-to-Noise ratio or SNR. It is the ratio of signal power to the noise power corrupting the signal.

In simple words, SNR (Signal-to-Noise Ratio) is a ratio based value that evaluates your signal based on the noise being seen. SNR is measured as a positive value between 0db and 120db and the closer the value is to 120db, the better.

Let's look at the components of the SNR and then understand how SNR is determined. SNR is comprised of 2 values.

a) Signal
b) Noise

RSSI (Recieved Signal Strength Indicator) is a more common name for the Signal value. It is the strength that one device is hearing another device. This value is measured in decibels from 0 (zero) to -120 (minus 120). The closer this value to 0 (zero), stronger the signal.

Typically voice networks require a -65db or better signal level while a data network needs -80db or better. Normal range in a network would be -45db to -87db depending on power levels and design. The Signal is also affected by the APs transmit power & antenna as well as the client's antenna.

Noise is any signal that interfers with your signal. Noise can be due to other wireless devices such as cordless phones, microwave devices etc. This value is measured in decibels from 0 (zero) to -120 (minus 120). Noise level is the amount of interference in your wireless signal, so lower is better. Looking at this value, if the value is closer to -120 (minus 120) it is better because that means there is little to no interference. Typical environments range between -90db and -98db.

To calculate the SNR value, we add the Signal Value to the Noise Value and it generates (or should) a positive number that is expressed in decibels (db). For example, lets say your Signal value is -55db and your Noise value is -95db.

-55db + -95db = 40db this means you have an SNR of 40, the general rule of thumb is that any SNR above 20 is good.

Other important terminologies that we need to understand is the EIRP and Free Space Path Loss.

EIRP (Effective Isotropic Radiated Power):

EIRP (Effective Isotropic Radiated Power) is the actual amount of signal leaving the antenna and is a value measured in db and is based on 3 values:

a) Transmit Power (db)
b) Cable Loss (db)
c) Antenna Gain (dbi)

To determine EIRP follow this equation:
- Cable Loss + Antenna Gain = EIRP

For example we have a Cisco 1242AG access points running at full power with a 6dbi antenna on the 802.11a radio and a 2.5dbi antenna on the 802.11bg radio.

802.11a EIRP = 17db (40mw) - 0db + 6dbi = 23db = 200mw of actual output power
802.11bg EIRP = 20db (100mw) - 0db + 2.5dbi = 22.5db = 150mw (approx) of actual output power

Based on the example above, in theory, if you were to measure it right at the antenna you could get an RSSI of -23 or -22.5 respectively.

Free space path loss:

Free space path loss is a weakening of the RF signal due to a broadening of the wave front.

It is a measure of how much signal power the device loses over a given distance. Typically the device loses about 0.020 db per foot in an outdoor or wide open office; doors, walls, glass, and etc. affect this. This is why as a client walks away from an AP, the signal gets weaker.

All this relates to the client because it determines the signal the client recieves, also keep in mind that when looking at the client you have to account for it's antenna as well much like the EIRP.

So if a client card has a 2 dbi antenna (although they are typically either 0dbi or 2.2dbi) that boosts the incoming signal, and assuming the actual RSSI signal being seen is -68db, then:

Actual RSSI + Antenna Gain = Displayed RSSI

-68db + 2db = -66db

Check out the Cisco Enterprise Mobility Design Guide for more detail information on WLAN Radio Frequency Design Considerations.

Here is the link to the document.

WLAN Radio Frequency Design Considerations