Cisco VG224 and redundant uplinks
Customer was asking about the feasibility of using both FastEthernet interfaces on a Cisco VG224 to provide an additional level of reliability / redundancy to analog voice ports. Given they are not running a dynamic routing protocol internally, I suggested they rely on spanning tree to make the decisions between what uplinks should be used actively, and modify the configurations appropriately.
Here's my before and after snippets...
Before:
interface FastEthernet0/0
ip address 10.10.10.40 255.255.0.0
duplex full
speed 100
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 10.10.10.254
After:
interface FastEthernet0/0
no ip address (ip address can't be here anymore)
duplex full
speed 100
bridge-group 1
!
interface FastEthernet0/1 (this is normally shut, make sure to no shut)
no ip address
duplex auto
speed auto
bridge-group 1
!
ip route 0.0.0.0 0.0.0.0 10.10.10.254
!
interface BVI1
mac-address 0123.0123.0123 (fictitious)
ip address 10.10.10.40 255.255.0.0 (same IP previously on F0/0)
!
bridge irb (Integrated Routing and Bridging)
bridge 1 priority 65535 (make as high as possible to reduce possibility of becoming root bridge)
bridge 1 protocol ieee (this is standard spanning tree protocol)
bridge 1 route ip
No comments:
Post a Comment